Установка старых версий пакетов на Centos


Недавно настраивал сервер и столкнулся с такой проблемой. На сервере установлен PHP 5.4, а для установки последней версии phpMyAdmin требуется PHP 5.5
Не всегда можно изменить версию PHP (обновить), поэтому нужно было установить более старую версию phpMyAdmin

Как это сделать.
Вводим следующую команду, она покажет какие есть доступные версии

# yum —showduplicates list phpMyAdmin

Результат выполнения
Available Packages
phpMyAdmin.noarch 4.0.10.19-1.el6 epel
phpMyAdmin.noarch 4.7.0-1.el6.remi remi
phpMyAdmin.noarch 4.7.1-1.el6.remi remi

Теперь мы знаем, что есть версия 4.0, которая будет работать под нашей версией PHP 5.4
Теперь для того, чтобы установить нужную версию, пишем следующее

# yum install phpMyAdmin-4.0.10.19-1.el6

Заметки программиста — выпуск 2 — проблемы вконтакте


В данном видео показано несколько «ошибок» популярной социальной сети вконтакте, которая вызывает несколько вопросов, а именно:
1. Почему нельзя корректно обрабатывать файлы 0 размера и выводить соответствующее сообщение, не ставя пользователя в затруднительное положение некорректным сообщением?
2. Почему вконтакте смотрит содержимое моих файлов, и если оно недоступно для просмотра вконтакте, оно не дает его загрузить, все так же выдавая некорректное сообщение?
2.а. Зачем вообще следить за мной?
2.б. Есть ли такой пункт в лицензионном соглашении при регистрации пользователя?
3. Почему некорректно обрабатываются тип файлов? Если нельзя загружать шифрованное и просто его переименовать (сменить расширение) файл можно загрузить. Соответственно либо не нужно следить (что желательно), либо научитесь обрабатывать содержимое нормально, php это позволяет…